Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
01-31-2019, 02:47 AM,
#1
Ignition timing (possible) issue?
New member here trying to get the cruiser sorted out before the Spring...

I bought this 2005 V-Star 1100 Classic a couple of years back. Long story short, the valves got stuck open and therefore bent, and I rebuilt the top end. The bike wouldn't idle right after the rebuild, and after I chasing an air leak for days, I did away with the double carb setup in favor of a KJS kit. Idle problem solved. On to the next problem...

The idle sounds almost right, but it is not as smooth as I think it should be. On the road things are not much better. Having owned a Harley that with with an ignition module that was completely off, the way this one runs is definitely reminiscing of it.

Has anyone had an ignition module go bad before? Does anyone know of a shop in the San Francisco/Bay Area that is familiar V-Star tunning?

Thanks in advance!
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  V STAR 1100 CUSTOM TIMING WARNING Over TWO Customs 10 21,442 05-27-2019, 05:53 PM
Last Post: jilbake
  Timing? Tony H. 1 1,418 05-27-2019, 05:41 PM
Last Post: jilbake
  Key won't turn in ignition (first post!!!) ejbrut 8 7,562 03-05-2017, 10:36 PM
Last Post: pauli466
  Timing 180 out? No fire after starter clutch change... tommyramone55 3 3,635 05-25-2016, 09:04 AM
Last Post: pauli466
  vstar ignition/starter issues Angelisdarker 2 3,206 05-23-2014, 02:22 PM
Last Post: Angelisdarker

Users browsing this thread:
1 Guest(s)