Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
09-02-2019, 06:44 AM,
#1
2009 V-star engine trouble
Up till recently bike ran fine. Started one morning now it runs very rough, no power, revs slow. Would appreciate troubleshooting ideas as I am assigned to Germany and bike work is expensive.
Reply
Possibly Related Threads...
Thread Author Replies Views Last Post
  Trouble with rewrapping H.265 to H.264/MPEG-4 MP4 - Solved CaitlinAaron 0 1,468 02-08-2018, 03:54 AM
Last Post: CaitlinAaron
  Engine Light is on when engine is running, and off when driving? fady.nowhere@gmail.com 0 1,733 10-04-2017, 08:16 PM
Last Post: fady.nowhere@gmail.com
Emoticon_unhappy 2001 Yamaha VStar 650 Classic Engine Knock upshiftoverdrive 0 2,434 07-29-2017, 01:10 AM
Last Post: upshiftoverdrive
  Replacement engine Itamar 1 2,900 06-06-2017, 10:27 PM
Last Post: bounce02
  Engine/transmission whine?? Florida_Rider 1 3,814 03-29-2017, 06:52 AM
Last Post: nick59
  99 xvs engine compatability barefoot 5 4,303 04-11-2016, 05:58 AM
Last Post: barefoot
  Can I replace my engine? eldonfavio 16 11,859 07-12-2015, 10:47 PM
Last Post: pauli466
  Starter spins but doesn't turn over the engine RichardR 17 27,098 04-12-2015, 04:01 AM
Last Post: RenoRider33
  Rattle to the right '01 1100 V Star Engine techtom 12 12,198 10-26-2014, 03:43 PM
Last Post: nick59
  650 engine dies after depress clutch and shifting VStar King 9 9,103 12-05-2012, 09:20 PM
Last Post: jmck

Users browsing this thread:
1 Guest(s)